Home / Errors & Fixes / How to fix “Could not issue a Let’s Encrypt SSL/TLS certificate for xyz.com” error

How to fix “Could not issue a Let’s Encrypt SSL/TLS certificate for xyz.com” error

If you are using Plesk, you might encounter this error during installation of Let’s Encrypt SSL Certificate.

This horrible looking error, is quite easy to fix. According to Plesk Knowledgebase, this error occurs because “Shared libraries used by the service were updated e.g. OpenSSL, glibc”.

To fix this error, you just need to restart the Server.

  • Login to Plesk
  • Navigate to Tools & Settings > Server Management and click on “Restart Server”

How to restart Plesk Server

After Server is rebooted, try to install Let’s Encrypt certificate and hopefully this time, it will install without any error.